Deprecation of DirectX10 support

The relentless march of technology brings with it many improvements but also requires us to make difficult decisions.

Adapting our rendering technology to utilise the maximum potential of modern DirectX libraries means that supporting older DirectX versions has become increasingly difficult and introduces instabilities into the game for all users. DirectX10 was first introduced with Microsoft Vista back in 2007, 11 years ago, and both Nvidia and AMD stopped supporting DirectX10 in their driver development several years ago

Though it has been possible to run BeamNG.drive on DirectX10 graphics cards, this did not meet our minimum system requirements, which have called for DirectX11 for some time. The developer resources required to maintain functionality on DirectX10 graphics cards has reached the point where continued support is not sustainable. It is for this reason that we have had to make the decision to cease ongoing support of DirectX10 in the same way we had to stop supporting the now 17 years old DirectX9.

We have made available a branch of the DX10 game client in Steam. This branch will not be updated beyond this point.
You can find instruction on how to use it here.

16 responses to “Deprecation of DirectX10 support”

  1. WentwardB60 says:

    Welp, looks like I’m never gonna be able to play the newest version of BeamNG.drive, then. 🙁

    I’m on macOS you see, and DX11 is technically impossible to run on macOS, from what I know.

    I’m really hoping you’ll someday add macOS support for this awesome, awesome game…

  2. timothy j green says:

    hi

  3. georgg1996 says:

    Was about time #sorrynotsorry dx10 users.
    But you see now devs will be able to improve various things that where near to impossible with the bugged up to hell dx10. Thanks for the continuous improvement and update for this awesome game! Looking forward for vulkan 👨‍💻👨‍💻👨‍💻

  4. DennisU says:

    I am trying to use the directx v10 version, followed the instructions to go to beta and get it, but i’m getting a prompt that requires a beta access code. Where do I get this?

  5. dkwenwen says:

    third bugfix for beamng version 0.15 was last version DX10 has support

  6. КОСТЯ says:

    КАКУЮ НАДО СКАЧАТЬ БМДЖ ДРАВ

  7. andriy says:

    мне нравиться ета гра

  8. NickolasUkriane says:

    Excuse me, im kinda dissapointed…
    When I try to play new 0.16 update, screen dosen’t work and stays black for some reason. Then, after some hours of waiting, my PC decided to oof to black screen. I think its a virus causing this, or its just me using a DirectX.

  9. bob says:

    where the hell is dx11

  10. Niall Jones says:

    I recently updated BeamNG but can no longer play it becasue of deprecation of DirectX10 support, I tried to access an older version by going to properties>beta as listed in these instructions
    https://wiki.beamng.com/Incompatible_DirectX
    but there is no older versions listed when I check. How can I access an older version to run on DirectX10 card?

Leave a Reply

Your email address will not be published. Required fields are marked *