Fourth hotfix release for 0.9

0.9.0.4

Content

  • Camo skin is now colourable. Added to Hopper and Roamer as well
  • Added spawnpoints to ‘ETK Driver Experience Center’ level
  • Added 15×9 version of Ibishu Trekker wheels

Bugfixes

  • Adjusted offset of 6-lug wheels and pickup/van/roamer track width (your custom configs with 6-lug wheels will need their track width widened by 0.02m if it’s saved in the .pc)
  • Fixed loading quickrace prefabs
  • Fixed props not being disabled when beams break/deform
  • Fixed moving/resetting vehicle while paused
  • Fixed Kickplate prop, now works properly and has an adjustable power setting
  • Added performance data to missing configurations (Hopper, Semi, Van)
  • Fixed BOV doing weird things with low inertia engines at redline
  • Adjusted ETK Gauges fuel display when the engine is turned off
  • Added noncolliding tris to Bolide, Sunburst, SBR4, Semi, tow hitches
  • Bolide fuel tank loose node fix
  • Added lockable hubs to Hopper
  • Tweaks to “Kickplate” and “Slippery” ground models

0.9.0.3

Bugfixes

  • Fixed Hopper duplicate brake slots
  • Fixed crash when a new quickrace is started while in an active quickrace
  • Fix D15 roof rack lights, some triangle issues, flexbody problem with 3-link suspension
  • Improve rigidity of bash bars
  • Rollover sled jbeam improvements
  • Fix G-meter instability on semi
Instructions on how to update the game here.
Bug reporting/Help Thread here.


Discuss in our community

19 responses to “Fourth hotfix release for 0.9”

  1. FS16 says:

    Aaand, what about a third one? Y'know, 1, 2, 3, 4, not 1, 2, 4…

    xD

  2. HDR says:

    "FS16, wrote:

    Aaand, what about a third one? Y'know, 1, 2, 3, 4, not 1, 2, 4…

    xD

    There was an update, but no devblog post was released for it

  3. FS16 says:

    "HDR, wrote:

    There was an update, but no devblog post was released for it

    alright then…

  4. "FS16, wrote:

    alright then…

    At the bottom of the "Fourth Hotfix Release For 0.9".

  5. SmileOnMe says:

    Is this update out on steam? I'm not getting it… tried restarting steam, reinstaling the game itself, but it's still 0.9.0.3… ๐Ÿ™ I'm upset ๐Ÿ™ But I still love the game ๐Ÿ™‚ Keep the good work ๐Ÿ˜‰

  6. HDR says:

    The update does not seem to have been pushed yet, it's not just you.

  7. Alex [ITA] says:

    Last minute bugfixes made the update to come out delayed on Steam. Just be patient. ๐Ÿ™‚

  8. im liking these perodic updates. Keeps the comminuity entertained well the next big update is being worked on

  9. Tommy1995 says:

    and it's great we don't only get bug fixes, a skin here or a new part there per hotfix is great

  10. Josh says:

    I love these quick updates :).

  11. Dam 4 hotfixes in the last week. That might be a new record!

  12. CaptanW says:

    "JoshTheAwesome, wrote:

    im liking these perodic updates. Keeps the comminuity entertained well the next big update is being worked on

    its nice but 1 a week would be the best.

  13. [ATTACH]262305  Not sure if its something on my end conflicting with mods, but with the black color, top and padding is white.

  14. Godzilla! says:

    "(GNG) wrote:

    wearyNATE15, post: 586691, member: 126573"][ATTACH]262305  Not sure if its something on my end conflicting with mods, but with the black color, top and padding is white.

    Clear cache, if that doesn't work then you might need to reinstall the game.

  15. Neobite says:

    Amazing the latest updates, before with only in truck I was playing the game at 14fps, now with the truck and 2 cars but I walk at 30Fps!

  16. colewski says:

    Does anyone else get this?

    BeamNG.drive 0.9.0.4 0xC0000005 STATUS_ACCESS_VIOLATION

    I spawned up the t-sires crashed them game with this error? does anyone have a solution to this?

  17. Nadeox1 says:

    "colewski, wrote:

    Does anyone else get this?

    BeamNG.drive 0.9.0.4 0xC0000005 STATUS_ACCESS_VIOLATION

    I spawned up the t-sires crashed them game with this error? does anyone have a solution to this?

    Does it happen each time? Could have just been a random crash.

  18. colewski says:

    "Nadeox1, wrote:

    Does it happen each time? Could have just been a random crash.

    Old cache problem Never mind ๐Ÿ™‚

Leave a Reply